Welcome, Guest
Username: Password: Remember me
Detailed ready-to-use tutorials about "City Car Driving" modding

TOPIC: How to Fix Issue of Mods' Engines Not Starting

How to Fix Issue of Mods' Engines Not Starting 20 Dec 2018 01:51 #111341

  • GSHAPIROY
  • GSHAPIROY's Avatar
  • OFFLINE
  • Guru
  • City Car Driving Mod Maker
  • Posts: 3638
  • Thank you received: 393
Navigate to C:\Program Files (x86)\Steam\steamapps\common\City Car Driving\data\physics\cars (for Steam version)

OR

C:\Program Files (x86)\Forward Development\City Car Driving Home Edition\data\physics\cars (for non-Steam version).

From here, open the folder of the car that needs fixing, and open the file 'p_player_setup.ini' with Notepad, Notepad++, or another text editor.

In the file, find something a heading looks like this:
[Engine2]
and delete everything that is within this heading (usually 1-3 lines of text). Then add the following below it instead:
MaxStarterTorque=200
MaxStarterRpm=650
MinStarterWorkTime=0.5
MinStarterGear=1
MaxStarterGear=2
RpmChangeSpeedStart=0.33
RpmChangeSpeedPow=0.5
RpmChangeSpeedMin=0.1
Now the mod will work again.
YouTube: goo.gl/tueUM9
VK Modding Group: vk.com/mods_by_gshapiroy

Current Vehicles:
2019 Honda HR-V Sport
2009 Kia Optima LX

David02 wrote:
You're my favorite.
Last Edit: 20 Dec 2018 01:52 by GSHAPIROY.
The administrator has disabled public write access.
The following user(s) said Thank You: KOZAN

How to Fix Issue of Mods' Engines Not Starting 20 Dec 2018 01:54 #111343

  • THETJVIDCHANNEL
  • THETJVIDCHANNEL's Avatar
  • OFFLINE
  • Global Moderator
  • Passion for Audi, BMW and Range Rover
  • Posts: 9780
  • Thank you received: 1611
Moved to Mods (General)/Tutorials

That does not fix the problem for all cars.

data\physics\cars
Open p_player_setup.ini

Find
MaxRpmAcc=####
MinRpmAcc=-####

If these numbers are above 7000, the car is likely not going to start. So change it to something lower than 7000.
Contact me in a PM if you have any concerns about users or the forum.

Mod Maker - Moderator - YouTube Video Creator

vk.com/tj_mods - VK Modding Page
www.youtube.com/THETJVIDCHANNEL - YouTube - TJ

Location - Melbourne, Australia - GMT +11:00

Favourite cars - 2020 Audi RS6 Avant - 2019 BMW X5 - 2018 Ferrari 488 Pista - 2019 BMW 3-Series - 2019 Range Rover Sport
Last Edit: 20 Dec 2018 01:55 by THETJVIDCHANNEL.
The administrator has disabled public write access.
The following user(s) said Thank You: GSHAPIROY, KOZAN

How to Fix Issue of Mods' Engines Not Starting 02 Jan 2019 15:57 #111457

  • kas1.4truckdriver
  • kas1.4truckdriver's Avatar
  • OFFLINE
  • Guru
  • Škoda and Volvo fan.
  • Posts: 4572
  • Thank you received: 1005
I made a video for this.
https://www.youtube.com/watch?v=qxkoXNfhgVI
Current cars that I drive in real life:
- Ford Transit Connect L2H2 2012
- Ford Transit L3H2 2014
- Opel Agila 1.2 2011
- Skoda Octavia Combi 1.4 Tsi 2016
The administrator has disabled public write access.
The following user(s) said Thank You: Niklas12, Ethan55195519

How to Fix Issue of Mods' Engines Not Starting 07 Jan 2019 20:54 #111500

  • KOZAN
  • KOZAN's Avatar
  • OFFLINE
  • Advanced user
  • Posts: 132
  • Thank you received: 6
Can someone make a tutorial how to uodate sounds for 1.5.7?
The administrator has disabled public write access.

How to Fix Issue of Mods' Engines Not Starting 07 Jan 2019 23:54 #111501

  • THETJVIDCHANNEL
  • THETJVIDCHANNEL's Avatar
  • OFFLINE
  • Global Moderator
  • Passion for Audi, BMW and Range Rover
  • Posts: 9780
  • Thank you received: 1611
KOZAN wrote:
Can someone make a tutorial how to uodate sounds for 1.5.7?
It needs to be remade like making a new sound.
Contact me in a PM if you have any concerns about users or the forum.

Mod Maker - Moderator - YouTube Video Creator

vk.com/tj_mods - VK Modding Page
www.youtube.com/THETJVIDCHANNEL - YouTube - TJ

Location - Melbourne, Australia - GMT +11:00

Favourite cars - 2020 Audi RS6 Avant - 2019 BMW X5 - 2018 Ferrari 488 Pista - 2019 BMW 3-Series - 2019 Range Rover Sport
Last Edit: 07 Jan 2019 23:56 by THETJVIDCHANNEL.
The administrator has disabled public write access.

How to Fix Issue of Mods' Engines Not Starting 14 Jan 2019 00:04 #111549

  • kas1.4truckdriver
  • kas1.4truckdriver's Avatar
  • OFFLINE
  • Guru
  • Škoda and Volvo fan.
  • Posts: 4572
  • Thank you received: 1005
Update:

I was updating all Denis154rus his mods, since I don't he will update them. but when you add the fix to the car, it makes the car impossible to drive. car makes all the time huge revs and doesn't shift to next gear. I haven't found a solution for this yet, but if someone already did please let us know!

The fix only works on some mods of iv777.
Current cars that I drive in real life:
- Ford Transit Connect L2H2 2012
- Ford Transit L3H2 2014
- Opel Agila 1.2 2011
- Skoda Octavia Combi 1.4 Tsi 2016
The administrator has disabled public write access.
The following user(s) said Thank You: ChrisTheIncredibleHD

How to Fix Issue of Mods' Engines Not Starting 14 Jan 2019 01:18 #111550

  • THETJVIDCHANNEL
  • THETJVIDCHANNEL's Avatar
  • OFFLINE
  • Global Moderator
  • Passion for Audi, BMW and Range Rover
  • Posts: 9780
  • Thank you received: 1611
kas1.4truckdriver wrote:
Update:

I was updating all Denis154rus his mods, since I don't he will update them. but when you add the fix to the car, it makes the car impossible to drive. car makes all the time huge revs and doesn't shift to next gear. I haven't found a solution for this yet, but if someone already did please let us know!

The fix only works on some mods of iv777.
Did you change the max RPM? You should only change max RPM acceleration (rev when in neutral or park). If the max RPM is lower than the RPM when the car shifts up, then the car wont shift.
Contact me in a PM if you have any concerns about users or the forum.

Mod Maker - Moderator - YouTube Video Creator

vk.com/tj_mods - VK Modding Page
www.youtube.com/THETJVIDCHANNEL - YouTube - TJ

Location - Melbourne, Australia - GMT +11:00

Favourite cars - 2020 Audi RS6 Avant - 2019 BMW X5 - 2018 Ferrari 488 Pista - 2019 BMW 3-Series - 2019 Range Rover Sport
Last Edit: 14 Jan 2019 01:21 by THETJVIDCHANNEL.
The administrator has disabled public write access.
The following user(s) said Thank You: ChrisTheIncredibleHD

How to Fix Issue of Mods' Engines Not Starting 14 Jan 2019 11:22 #111557

  • kas1.4truckdriver
  • kas1.4truckdriver's Avatar
  • OFFLINE
  • Guru
  • Škoda and Volvo fan.
  • Posts: 4572
  • Thank you received: 1005
THETJVIDCHANNEL wrote:
kas1.4truckdriver wrote:
Update:

I was updating all Denis154rus his mods, since I don't he will update them. but when you add the fix to the car, it makes the car impossible to drive. car makes all the time huge revs and doesn't shift to next gear. I haven't found a solution for this yet, but if someone already did please let us know!

The fix only works on some mods of iv777.
Did you change the max RPM? You should only change max RPM acceleration (rev when in neutral or park). If the max RPM is lower than the RPM when the car shifts up, then the car wont shift.

I changed MaxRpmAcc=#### & MinRpmAcc=-#### because all of Denis his mods have numbers above 7000.
Current cars that I drive in real life:
- Ford Transit Connect L2H2 2012
- Ford Transit L3H2 2014
- Opel Agila 1.2 2011
- Skoda Octavia Combi 1.4 Tsi 2016
The administrator has disabled public write access.

How to Fix Issue of Mods' Engines Not Starting 14 Jan 2019 11:30 #111558

  • THETJVIDCHANNEL
  • THETJVIDCHANNEL's Avatar
  • OFFLINE
  • Global Moderator
  • Passion for Audi, BMW and Range Rover
  • Posts: 9780
  • Thank you received: 1611
kas1.4truckdriver wrote:
THETJVIDCHANNEL wrote:
kas1.4truckdriver wrote:
Update:

I was updating all Denis154rus his mods, since I don't he will update them. but when you add the fix to the car, it makes the car impossible to drive. car makes all the time huge revs and doesn't shift to next gear. I haven't found a solution for this yet, but if someone already did please let us know!

The fix only works on some mods of iv777.
Did you change the max RPM? You should only change max RPM acceleration (rev when in neutral or park). If the max RPM is lower than the RPM when the car shifts up, then the car wont shift.

I changed MaxRpmAcc=#### & MinRpmAcc=-#### because all of Denis his mods have numbers above 7000.
And the gears arent changing? What is the max RPM (maxRPM=####)?
Contact me in a PM if you have any concerns about users or the forum.

Mod Maker - Moderator - YouTube Video Creator

vk.com/tj_mods - VK Modding Page
www.youtube.com/THETJVIDCHANNEL - YouTube - TJ

Location - Melbourne, Australia - GMT +11:00

Favourite cars - 2020 Audi RS6 Avant - 2019 BMW X5 - 2018 Ferrari 488 Pista - 2019 BMW 3-Series - 2019 Range Rover Sport
The administrator has disabled public write access.

How to Fix Issue of Mods' Engines Not Starting 14 Jan 2019 13:48 #111559

  • kas1.4truckdriver
  • kas1.4truckdriver's Avatar
  • OFFLINE
  • Guru
  • Škoda and Volvo fan.
  • Posts: 4572
  • Thank you received: 1005
THETJVIDCHANNEL wrote:
kas1.4truckdriver wrote:
THETJVIDCHANNEL wrote:
kas1.4truckdriver wrote:
Update:

I was updating all Denis154rus his mods, since I don't he will update them. but when you add the fix to the car, it makes the car impossible to drive. car makes all the time huge revs and doesn't shift to next gear. I haven't found a solution for this yet, but if someone already did please let us know!

The fix only works on some mods of iv777.
Did you change the max RPM? You should only change max RPM acceleration (rev when in neutral or park). If the max RPM is lower than the RPM when the car shifts up, then the car wont shift.

I changed MaxRpmAcc=#### & MinRpmAcc=-#### because all of Denis his mods have numbers above 7000.
And the gears arent changing? What is the max RPM (maxRPM=####)?


I updated all of his mods. in case of MaxRPM=25000 I removed a 0 and made it 2500, what do you think? to radicale? should I change it too 6999, or try it with 25000?
Current cars that I drive in real life:
- Ford Transit Connect L2H2 2012
- Ford Transit L3H2 2014
- Opel Agila 1.2 2011
- Skoda Octavia Combi 1.4 Tsi 2016
The administrator has disabled public write access.
Time to create page: 0.184 seconds