Welcome, Guest
Username: Password: Remember me
"City Car Driving" general discussion forum for English users
  • Page:
  • 1

TOPIC: G920 pedal dead zone

G920 pedal dead zone 22 Dec 2019 14:58 #113421

Hi,

I got the game yesterday. I have a G920 wheel. Regardless of how I set it up and how hard I press the pedals, I cannot fully depress the brake or the clutch. The dead zone and linearity sliders do seem to improve it, but ever so slightly. I've uploaded a picture of the sliders with both the clutch and brake pedals fully depressed.
20191222135358_1.jpg

I should also mention that I've had no problems with my hardware in a number of different racing games.

Any suggestions would be appreciated!
Thanks!
The administrator has disabled public write access.

G920 pedal dead zone 23 Dec 2019 10:27 #113426

  • Kivlov
  • Kivlov's Avatar
  • OFFLINE
  • Developer
  • Posts: 229
  • Thank you received: 29
Hello,

If you're using a racing wheel you should set up it properly.

Before starting the game, please perform these steps:

1. Update your wheel driver to the latest version from your controller manufacturer's website.
2. Calibrate your wheel and check if it works correctly in Windows.
3. Please note that you should connect your wheel to the PC and wait until the very end of its auto calibration strictly before(!) launching the simulator.

Then start the game and follow the directions below:

First, reset all the game settings to default.

Then, check if your wheel has the ready settings preset in the game controls menu. If it has one – just select your wheel from the dropdown list. Everything should work automatically from this point for your wheel model.
The administrator has disabled public write access.

G920 pedal dead zone 23 Dec 2019 13:25 #113431

Hello,

1. I am running the latest drivers and have Logitech Gaming Software installed.
2. The wheel is set up properly. It works fine as it is in other games.
3. I don't start the game before auto calibration is complete.

I did select the wheel preset from the controls menu. The problem is that the dead zone slider does almost nothing. This is me changing the slider from min to max while applying constant pressure on the clutch pedal:

20191223122202_1.jpg


20191223122215_1.jpg
The administrator has disabled public write access.

G920 pedal dead zone 25 Dec 2019 22:07 #113447

  • KOZAN
  • KOZAN's Avatar
  • OFFLINE
  • Advanced user
  • Posts: 151
  • Thank you received: 10
Try uncheck combined pedals in logitech game center.
The administrator has disabled public write access.

G920 pedal dead zone 26 Dec 2019 18:23 #113453

Combined pedals is unchecked
The administrator has disabled public write access.
  • Page:
  • 1
Time to create page: 0.178 seconds